What are the system requirements for Version 5?

General IT Requirements

RequirementCloud ServiceSelf-Hosted / On Premises
Windows IIS Servers VM

Connect to SQL Server

Branded hostname with public authority

Dedicated SMTP IP


Maintain IIS servers, SQL, and PoliteMail


Graph app key

Trust PoliteMail SMTP server with M365 connector

Minimum System Requirements

PoliteMail for Outlook (COM Add-In)

  • Microsoft Outlook for Windows 2016+ or Outlook for Microsoft 365 MSO
  • Microsoft Windows 10, 11 (May 2019 update or greater with .Net 4.8)
  • Desktop installer (setup.exe) adds functionality into Outlook interface
  • SSO with OpenID, OAuth2, SAML2
  • Graph API key and internal SMTP endpoint

PoliteMail 365 (Modern Add-In)

  • Microsoft 365 Outlook Online (Windows or Mac)
  • Up-to-date modern Web browsers including Edge, Chrome, Firefox, Opera, and Safari.
  • Manifest deployment in Microsoft 365 (Admin Center under Settings > Integrated apps)
  • SSO with OpenID, OAuth2, SAML2
  • Graph API key and internal SMTP endpoint

PoliteMail Online

  • PoliteMail Online can be accessed through any up-to-date modern Web browser including Edge, Chrome, Firefox, Opera, and Safari, or with Outlook 365 with the PoliteMail 365 Add-In.
  • PoliteMail Online integrates with Exchange Server 2013 and higher.
  • SSO with OpenID, OAuth2, SAML2
  • Graph API key and internal SMTP endpoint

PoliteMail Server (BYOC)

  • Azure or AWS Account, with VM or containerized Windows Server Images and SQL Server or Azure SQL backend.
  • Learn how to scale cloud services based on the number of employees.

On-Premises Server

Server software is required for self-service installation but is included with Cloud services.

  • Exchange Server 2013+ and Exchange Online
  • Windows Server 2016+ with IIS
  • SQL Server 2016+
  • Learn how to scale SQL based on the number of employees.